High sirres 小幅升级带来的奇怪问题

miroslav-skopek-526075-unsplash.jpg

  在不久前,手贱下载了最新的High sirres 来升级「直接从App store 升级有阴影」;升级后的一段时间内「不短不长」一如既往的稳定,直到我用NPM 安装新依赖时提示:xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

  在之前遇到过类似的问题「没有xcode 或CLI 工具」,但这次是提示需要xcode。。。老子只是装点依赖,用得着上几个G的xcode 吗!这是不合理的要求,要抗争到底「搜索>_<」。

  由于没有完全匹配或较高匹配的结果,辨别所花费的时间还是不少的。最后还是在著名的stackoverflow 找到了答案。嗯,你没看错;执行下面的命令就可以了「前提是你安装了xcode-select」。高票答案是建议安装xcode 并且解析了报错的原因「虽然我觉得有点笼统」。

sudo xcode-select -switch /Library/Developer/CommandLineTools
您的浏览器已过时

要正常浏览本网站请升级您的浏览器。现在升级

×