No matching version found for xxx

  在我重新安装依赖的时候「node_modules 已经删除了」,npm 报错了;提示No matching version found for http-signature@undefined,整个安装也中断了。不死心的我,又试了几遍都不行。最终还是在[stackoverflow][1] 上找到解决办法。

  只要将package-lock.json 移除就可以了;虽然stackoverflow 上的回答有人附言说这不是解决办法,因为package-lock.json 记录的是锁定版本的信息,如果这个文件不存在的话,npm 会根据package.json 的配置范围,安装最新的版本

您的浏览器已过时

要正常浏览本网站请升级您的浏览器。现在升级

×